Why ESCs don’t power on when everything is connected?

1.99K viewsmini quad (<250mm)
0

When everything is connected my ESCs do not power on when I plug in the battery. The Naze32 and receiver both power on. The Naze shows a solid red LED. If my receiver is unplugged and I plug in the battery my naze and ESCs power on like normal and I am able to throttle up in the cleanflight motor tab. If everything is hooked up and I have my battery plugged in and my naze connected to cleanflight everything powers on normally including ESCs and I can arm the board with my transmitter and throttle up.

Setup is Acro Naze32, d4r-2 receiver, emax 12a escs, and sunnysky 2204 2300kv motors

Hi, how are you powering your flight controller? Can you upload some photos of your wiring? It sounds like your escs only get a signal when you have your usb connected to your flight controller, which can sometimes mean that there is a ground loop in your build. Did you connect the reference grounds to your escs?

I’m not at home to get pictures right now but the ESCs will power on with only battery power as long as my receiver is disconnected from the naze. Yes I have all of the ground wires connected. I am powering the flight controller using the BEC in my ESC. When I get home I’ll get some pictures of the wiring.

1

It turned out to be a faulty Naze32. I ordered a new one and made sure it was an original and it works great.

commented

Thanks for posting your solution, A faulty Naze32 is not a common thing, Is it possible that you had a Naze32 without a diode (pre rev6B?)

Question stats

  • Active
  • Views1992 times
  • Answers1 answer