TBS QQ190 setting up new radio (spektrum)

3.93K viewsQQ190 RTF Ready to Fly Racing Drone
0

I have a TBS QQ190 drone and I got a new radio transmitter (Spektrum DX8). Im trying to connect the new radio to the QQ190 but it is not allowing me. The OSD is still displaying the old radio as if it were still connected to the receiver. I have pushed and held the “ENTER” button on the left side, second to bottom stack for 10 seconds hoping that it takes me to the calibration page. Although, it does take me to the calibration page to move the sticks to the center, but as I do that nothing happens. I also make sure that the receiver displayed for connection is the “Spektrum 2048”. When I first binded the receiverĀ to the Specktrum DX6, after centering sticks I would get a count down on the OSD and so on and so forth with the yaw, roll, pitch, etc. BUT with this new DX8, nothing is happening. Is there something I need to do to wipe this drone clean besides the tune so I can try to get the DX8 connected?

 

The Spektrum receiver stays a solid red light, which states its obviously bounded to the Spektrum DX8. Its getting the drone to get signal input from the radio.

0
Anonymous 0 Comments

This is outlined in the manual, available at manual.qq190racingdrone.com

 

You can fix this by flashing the QQ190 with the TBS Agent, or by connecting to Betaflight.

There was a minor error in the programming of the first batch of QQ190RTFs that went out,

If you are unfamiliar with Betaflight, you can fix this by using the TBS agent software.

Download TBS Agent atĀ http://agent.qq190racingdrone.com. Must use with Windows.

Follow these steps:

1. Install and launch the TBS Agent Application

2. Connect a mini usb cable to the top board of your electronics stack (do not hold the boot button on the top of the board down when doing this)

3. Select the beta-releases download checkbook on the Update tab.

4. Select the Colibri race update tab.

5. Choose Betaflight 3.1.x whichever is the most recent.

6. Update the board to the latest version

7. Choose the betaflight QQ firmware and flash the custom QQ version.

8. Unplug from computer and run through the R/C setup via OSD on goggles.

If you do not see the RC calibration screen after completing the flashing, hold the button on the side of the cube down for 10 seconds.

If you are familiar with Betaflight, you simply need to turn off the serial Rx function of serial port 1. The issue is happening because serial RX is on for both ports 1 and 2.

Let me know if that fixes it!

Question stats

  • Active
  • Views3931 times
  • Answers1 answer