How to setup RGB LEDs on a Blade 150 or Naze32

Solved670 viewsnaze32blade-150 leds naze32 programming
0

Hi,

Working on my first ever build of a Blade 150 for pure LOS flying only. I got some RGB LED’s so I can have some model orientation indicator in flight as well as alarm flashing when voltage is low. I’ve powered the LED via one of the ESC headers. And I’ve got the Signal wire connected to #5. Now I have 2 questions:

  1. The LED has a very faint spec of a glow. I tested the LED using the LED 5V out on my BEC, but the general web consensus is to use the ESC header for 5V power. LED was bright from the BEC, but barely lighting from the ESC header. Any advice here?
  2. I cannot get LED Strip programming to work. Just trying to set a color at this point. I have LED_Strip turned on and am pretty sure I understand the LED Strip setup in Cleanflight. Is there something I have to do to enable the Soft Serial communication on pin #5?

Thanks for any help you can provide!

-Ed

edited question
0

Hi, It is very difficult to troubleshoot this without knowing what LEDs you are using.  If they are indeed 5V, then connecting to an ESC’s BEC should do it, but if they are dim- this might be due to your ESC’s output not being 5V, or not capable of supplying the current needed to power the leds.

If in doubt, you can run a separate BEC available here:

Micro BEC Voltage Regulator for quadcopter. B.E.C.

We are working on a youtube video on programming the LED lights-  I will try to remember to post it here once it is finished.

For now, check out this video on LED wiring to a Naze32:

selected as best answer

Question stats

  • Active
  • Views670 times
  • Answers1 answer