QQ190 – loss of VTx power output and RC range

0

I have a QQ190 with powercube, purchased new from TBS approx 4 weeks ago. So far it’s been flying without a problem (sensational), VTx set to 500ma using a Spektrum 4649t diversity Rx with a Spektrum DX8. Went for a fly at my local field yesterday and discovered my video output and RC range had both dropped considerably for no apparent reason. The VTx is now equal to about 25~50ma and I lost RC control twice. This is my test field, I know it well and up until now I have had great video range and never lost RC control. I have tried changing power output and it makes no difference and the drop in RC range has me stumped. I don’t do acro, just speed cruising fpv. Haven’t had any crashes yet, so I can’t put it down to impact damage, it has just happened out of the blue. I think the VTx and Rx use different layers in the cube(?) which makes me wonder why my video and RC have both lost range simultaneously. Can anyone suggest what I do from here? I don’t understand the cube well enough to know what to do or look for to get this sorted. Any help much appreciated. TIA.

Edit Post   Reply   Reply With Quote    

0
Jeremy (anonymous) 0 Comments

It would seem that updating to OSD FW 2.02 had locked my VTx power output to a low setting. Even though I could access and see the different outputs/bands and channels, it was locked at somewhere between 25~200ma at a guess. Reverting OSD FW back down to 1.72 has solved my problem and can now access all bands and power up to 800ma working. Can’t explain the RC dropout, perhaps just a coincidence.

Question stats

  • Active
  • Views592 times
  • Answers1 answer