Quad fell out of the sky, Naze32 won’t arm, strange 2 second beeping

1.46K viewsnaze32crash esc naze32
0

Today after flying fine the past few days, my QAV250 fell out of the sky mid-flight.  When powered back up, it started doing a quick beep every two seconds.  Now, it won’t arm, and it won’t connect to baseflight.  The grass was wet today, so perhaps some water got on the board?   I’ve let it sit in the sun for an hour.  No change.  Any idea what happened?

Thanks!

0

The naze32 has alternating red/green lights.  I read that means the accelerometer and/or magnetometer us trying to calibrate.  I tried reflashing baseflight, but since it won’t connect, I can’t reflash.

Looks like the Naze is a goner.

commented on answer

Did you try turning on autoconnect? ? Are you running an osd or any other serial device on uart 1? That can sometimes cause serial connectivity issues.

1

Hi,

These are strange symptoms- You will probably want to try reinstalling the firmware on your naze32.   Sometimes crashes can cause these things to happen.

What’s even more strange is that the ESCs don’t do their confirmation beeps which makes us think that you fried the Flight Controller.

If the naze32 will not connect to the computer, check that you have the correct drivers installed,  try a different USB cable.

If none of the above work, try checking that your flight controller is still getting power, and if it is, then try replacing the flight controller board.

Question stats

  • Active
  • Views1457 times
  • Answers2 answers