QQ190 – Motors continue to accelerate even when throttle is low.

0

Hi QQ. I flew my QQ190 for the first time in about a year the other day. Just been sitting on the shelf. When I arm my motors and select my usual flight mode (airmode/antigravity/horizon) and go to take off, the motors start to accelerate as normal, but then keep accelerating despite my throttle position. eg: if I aim to hover, it will start to hover then very rapidly keep accelerating skywards – the only solution is to drop my throttle to 0 or disarm the motors. I literally need to let it fall to the ground. This happens in all modes (acro, etc.). Prior to this, it flew like an F-16 on rails. I have recalibrated the ESC’s a dozen times, calibrated the accelerometer and re checked all other settings (PID’s etc). In desperation, I updated to the latest Betaflight Calibri_Race 3.5.0, tuned it (without issue) to fly as previous, hoping the upgrade might somehow solve the problem, not so – issue remains. I don’t think it’s the ESC’s as they calibrate fully and successfully on all motors, the motors are pretty much just slaves – could it be the FC signal to the ESC’s?? What confuses me, is that no changes or events happened to it between successful flying and this problem – just time on the shelf. Can I replace the FC in the powercube – could that be the issue. I’m assuming they are still sold and will just slot in place in the powercube – would rather not, but I can’t think what else could be causing this. Any advice much appreciated. Cheers. Jeremy

Answered question
0

Sorry Anthony, just hooked up my goggles and my OSD/name/mw output hasn’t changed, nor the channel, looks as it should. Guess i don’t need to do an RC calibration again?? Or do I?

Posted new comment

The Reset should only reset the throttle calibration, your channel shouldn’t change. If it does, it should be a quick reset of your goggle channels before you are flying again.

Yes, it did only re-cal the throttle, nothing else changed – I just thought I’ve have to to a full rc recalibration, but not so. That Is really good to know, Thank You.

0

Hi Anthony. It’s been so long since I’ve been regularly using my QQ190, I’d forgotten how completely the re-set button actually “re-sets” (groan). Will need to go back in to calibration, try and find 5865- Band A channel 1 on my goggles and go through the RC cal procedure before I can make a call on whether or not that’s fixed it. Wish I’d noted my original band/channel as it performed so well around here. Never mind. Based on your comments, I feel it might just do it. I will report back for the record. Cheers.

Answered question
0

I’m happy to help 😊.

Holding the button during power up should have put the osd into default calibration.

See page 27 of the manual here.

https://drive.google.com/a/quadquestions.com/file/d/0B4vs1qfDGt6AWWJTM25CUGt2Ymc/view?usp=drivesdk

If it doesn’t go into osd calibration, my thoughts would be that perhaps the osd has been flashed to a different version?

The QQ190 will always go full throttle on the bench in air mode with auto level. If there are no props attached.  The quad will just continue to raise the throttle  to try to find level.

If it’s on the bench without props, putting it into rate mode should fix the throttle up issue that you are witnessing . Let me know what you find.

Answered question
0

Hi Anthony. Thanks for the super quick response. I have held the button on the side of the cube down during power-up to calibrate (not sure how long to hold it?) and this seems to have helped somewhat when I’m in Angle or Acro, that is to say, the throttle stays at the selected speed and will increase or decrease on using the throttle. Unfortunately, in Airmode, the motors idle nicely and low when selected (as they should), but once I start to move the throttle up, the motors slowly start to accelerate of their own accord and will climb to almost 100% if I don’t intervene. Will head back into Betaflight tomorrow and check my low throttle setting (although in Angle/Acro, the motors won’t spin unless I move the throttle off zero position ie: seems to be fine in that regard. I will also calibrate through the OSD as an alternative to the button hold, just for the hell of it. Just trying to avoid having to buy a new FC 🙁 Cheers and thanks again. Jeremy

Answered question
0

Hi Jeremy,  Thank you for posting here.  That is a very strange problem indeed.  It could be possible that your throttle is not calibrated to zero.  Can you take off the props and see what betaflight is telling you it’s doing? Posting screenshots here of the values could help.

I would make sure the radio is calibrated to the Colibri flight controller at the beginning of each flying season either by going through the OSD to initiate calibration, or by holding down the button on the side of the power cube with props off during power on to reset the calibration.

Let me know if that helps you get to the bottom of it!

Again, Thanks for using our ASK forum!

Sincerely,

Anthony

QQ

Unselected an answer

Question stats

  • Active
  • Views181 times
  • Answers5 answers